ES6 그리고 IE8

프론티어2017-03-05 22:17:1098910ie8, ie9, es6, webpack

ES6 (ECMAScript 2015) 를 사용하면서 IE8 지원문제가 늘 부담스러웠습니다.

물론 IE8 에서도 ES6 를 사용할수 있도록 Babel 등 Transpiler 를 사용할 수 있지만
(참고 : http://meetup.toast.com/posts/85 - 이글은 따로 정리해 볼까 합니다.)
일정부분 제약이 따르고,
특히나 webpack 2 로 넘어오면서 그 제약이 크게 느껴지더군요.

그동안 IE8 지원을 기본으로 고려했었는데
오늘을 기점으로 IE8 지원은 더이상 고려하지 않기로 했습니다.

Good Bye IE8~

이미지